Home ยป Memisahkan 2 Line Internet untuk 2 LAN di 1 Mikrotik

Memisahkan 2 Line Internet untuk 2 LAN di 1 Mikrotik

by anaknongkrong
Line Internet

Beberapa waktu yang lalu, dikantor saya memasang 2 line internet dengan ISP yang sama tetapi berbeda jenis layanannya. 2 line internet itu diatur harus berjalan semuanya dengan 1 router mikrotik dan beberapa jaringan LAN yang berbeda-beda segmen ipnya. Beberapa yang saya dapatkan di internet, kebanyakan adalah dengan sistem load balancing dimana 1 line jaringan itu mati, maka line yang satunya menggantikannya, tapi kali ini berbeda dimana 2 line itu harus berjalan untuk melayani kebutuhan internet divisi lainnya.

Topologinya seperti ini :

2 line internet

Dari topologi tersebut dimaksudkan bahwa user dengan IP 10.10.5.1/24 menggunakan ISP dengan IP 192.168.4.70/30 dan 192.168.4.74/30 sebagai koneksi internetnya. Begitu juga user dengan IP 10.10.6.1/24 menggunakan ISP dengan IP 36.94.216.107/24 sebagai koneksi internetnya.

Untuk menjalankan topologi seperti diatas, berikut saya berikan contoh settingan di server mikrotik yang sudah saya terapkan dan berjalan dengan normal hingga sekarang.

Pertama, lakukan konfigurasi IP Addressnya terlebih dahulu (sesuikan IP Address dengan jaringan milik anda)

/ip address
add address=192.168.4.70/30 interface=ether1-isp1iix network=192.168.4.68
add address=192.168.4.74/30 interface=ether2-isp1int network=192.168.4.72
add address=36.94.216.107/24 interface=ether3-isp2 network=36.94.216.0
add address=10.10.5.1/24 interface=ether4-lan1 network=10.10.5.0
add address=10.10.6.1/24 interface=ether5-lan2 network=10.10.6.0

Lalu buatlah mangle untuk memisahkan jalur trafficnya

/ip firewall mangle
add action=mark-routing chain=prerouting new-routing-mark=ISP1 passthrough=no src-address-list=koneksi1
add action=mark-routing chain=prerouting new-routing-mark=ISP2 passthrough=no src-address-list=koneksi2

dari konfigurasi diatas, IP address saya pisahkan dengan address list supaya apabila ada penambahan IP LAN, saya tidak perlu menambahkan rule di mangle, cukup menambahkan IP di address list dan nama yang disesuaikan mau dilewatkan ke jalur internet yang mana.

Setelah itu buatlah NAT masquerade atau src-nat, sesuaikan dengan sistematika jaringan koneksi yang ada di tempat kamu. Di tempat saya memakai src-nat karena ada beberapa IP publik yang bisa diakses sehingga IP private jaringan harus diarahkan ke ip publik yang mana. Tapi kali ini saya contohkan memakai NAT masquerade saja.

/ip firewall nat
add action=masquerade chain=srcnat

Sekarang buatlah route policynya

/ip route rule
add dst-address=10.10.5.0/24 table=main
add dst-address=10.10.6.0/24 table=main
add dst-address=192.168.4.0/24 table=main
add dst-address=36.94.216.0/24 table=main
add src-address=192.168.4.0/24 table=isp1
add src-address=36.94.216.0/24 table=isp2
add routing-mark=ISP1 table=ISP1
add routing-mark=ISP2 table=ISP2

Dan terakhir, buatlah default gatewaynya dan setup fail over untuk menjaga uptime

/ip route
add distance=1 gateway=192.168.4.73 routing-mark=isp1
add distance=1 gateway=36.94.216.106 routing-mark=isp2
add distance=1 gateway=192.168.4.73
add distance=2 gateway=36.94.216.106

Setelah selesai maka tinggal kita uji dengan cara melakukan trace route ke 8.8.8.8 pada masing-masing LAN dan mengecek ip publik keluaran masing-masing jaringan, sama ataukah berbeda. Apabila berbeda maka kamu sukses dalam settingan kamu.

Berikut sedikit catatan saya pada saat setting server jaringan dikantor saya. Apabila anaknongkrong ada yang bingung penjelasan diatas dan dihadapkan dengan topologi yang sama, jangan segan-segan kontak saya di halaman contact .

You may also like

1 comment

Mengenal Mikrotik - Konggres 17 March , 2021 - 6:39 am

[…] waktu yang lalu saya pernah cerita mengenai memisahkan 2 line internet untuk 2 lan di 1 mikrotik. Tapi setelah itu ada yang bertanya mengenai router mikrotik dan cara kerjanya seperti apa. Nah, […]

Reply

Leave a Comment

We use cookies to personalize the website for you and to analyze the use of our website. You consent to this by clicking on "I consent" or by continuing your use of this website. Further information about cookies can be found in our Privacy Policy. I consent

Privacy & Cookies Policy